现在的位置: 首页我爱Linux>正文
Centos 5.4 Xorg 启动不了
发表于7年前 我爱Linux 暂无评论 ⁄ 被围观 1,251 次+

Centos 5.4 Xorg 启动不了

今天我用图形界面安装了CentOS 5.4, 可是启动的时候却进不了X. 用FC12 LiveCD测试, 可以进入图形界面. 不知道哪里出问题了. xorg.conf 不能自动配置.
主板: Intel 965G 集成显卡.

麻烦大家帮忙看看. 谢谢!

下面是系统信息和Log:

# cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display
Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Section "InputDevice"
# keyboard added by system-config-display
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105+inet"
        Option      "XkbLayout" "us"
EndSection
Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
#

root@localhost X11]# cat /var/log/Xorg.0.log
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:39:04 EST 2010 i686
Build Date: 03 September 2009
Build ID: xorg-x11-server 1.1.1-48.67.el5
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan  1 10:20:42 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Videocard0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(==) No FontPath specified.  Using compiled-in default.
(==) FontPath set to:
        unix/:7100,
        built-ins
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(==) Max clients allowed: 512, resource mask: 0xfffff
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.3
        X.Org Video Driver: 1.0
        X.Org XInput driver : 0.6
        X.Org Server Extension : 0.3
        X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "bitmap"
(WW) Warning, couldn't open module bitmap
(II) UnloadModule: "bitmap"
(EE) Failed to load module "bitmap" (module does not exist, 0)
(II) LoadModule: "pcidata"
(WW) Warning, couldn't open module pcidata
(II) UnloadModule: "pcidata"
(EE) Failed to load module "pcidata" (module does not exist, 0)
Fatal server error:
Unable to load required base modules, Exiting...
(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
#

cat /var/log/anaconda.xlog
......
(--) Chipset 965G found
(II) intel(0): Integrated Graphics Chipset: Intel(R) 965G
.......

# system-config-display
Couldn't start X server on card 0
Couldn't start X server with old config, trying with a fresh configuration
Couldn't start X server on card 0
Error, failed to start X server.
# Xorg -configure :0
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:39:04 EST 2010 i686
Build Date: 03 September 2009
Build ID: xorg-x11-server 1.1.1-48.67.el5
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan  1 10:39:12 2006
(EE) Failed to load module "bitmap" (module does not exist, 0)
(EE) Failed to load module "pcidata" (module does not exist, 0)
Fatal server error:
Unable to load required base modules, Exiting...
#

# cat Xorg.setup.log
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:39:04 EST 2010 i686
Build Date: 03 September 2009
Build ID: xorg-x11-server 1.1.1-48.67.el5
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Sun Jan  1 10:38:49 2006
(++) Using config file: "/tmp/tmpEezFeMxorg.config"
(EE) Failed to load module "bitmap" (module does not exist, 0)
(EE) Failed to load module "pcidata" (module does not exist, 0)
Fatal server error:
Unable to load required base modules, Exiting...
#

lidexiang 发表于 2010-01-26 23:15:22

# yum install xorg-x11-server-Xorg
# Xorg -configure :0
# cp /root/xorg.conf.new /etc/X11/xorg.conf

这样就可以了.!

转载自: http://bbs.chinaunix.net/archiver/tid-1938602.html

给我留言

留言无头像?