现在的位置: 首页PHP应用>正文
CentOS用yum安裝PHP5.2.X
发表于8年前 PHP应用 评论数 2 ⁄ 被围观 3,709 次+

wordpress 更新到3.2,php版本最低要求是5.2.4,而centos默认yum安装的版本是5.1.6,所以新版本的wordpress不能使用.到网上搜索了一下,以下的方法可以安装php5.2.10.而且没有错误.

原文请看http://blog.lilujun.com/post/1208/

由於CentOS默認yum安裝php的版本是5.1.6,使用yum update命令不能升級php到最新版本。並且PHP在5.2之前都有個小小的錯誤,升級到最新版的PHP是非常有必要的。

安装使用testing库的许可
        rpm -import  http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing

        以下為在CentOS5.4用yum安裝PHP5.2.9的步驟。首先在/etc/yum.repos.d/CentOS-Base.repo 文件末尾添加以下代碼:

         [c5-testing]
         name=CentOS-5 Testing
         baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
         enabled=0
         gpgcheck=1
         gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing

        保 存此文件,執行yum --disablerepo=\* --enablerepo=c5-testing install php 接著根據提示Y同意執行,另外如果裝有ZEND,則根據實際情況是否需要修改zend在php.ini和選擇正確對應的ZendOptimizer.so ,然後再執行service httpd restart 重啟Apache。最後輸入php -v 檢查是否已經升級成功。

以上方法 在2012-04-26测试又不能成功安装了,先又寻找的一种方法:

先将以下地址导入。

# rpm --import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

# vi /etc/yum.repos.d/CentOS-Base.repo 增加下面信息

[utterramblings]
       name=Jason's Utter Ramblings Repo
       baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
       enabled=1
       gpgcheck=1
      gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

然后 yum install php ,能够安装成功.

PHP 5.2.17 (cli) (built: Aug 31 2011 17:06:47)
      Copyright (c) 1997-2010 The PHP Group
      Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
 

目前有 2 条留言 其中:访客:1 条, 博主:1 条

  1. guest : 2011年07月08日15:29:33  -49楼 @回复 回复

    centos的邮件服务器怎么配置?

    • 夜舞 : 2011年07月08日15:32:51 @回复 回复

      邮件服务器没配过,不过可以到鸟哥那里去看看,现在初学linux一般都看鸟哥的linux私房菜

给我留言

留言无头像?